Joomla 2.5.25. Устранение проблем на сайте

Первая проблема выявила вторую проблему. Но я их решил! Расскажу все по-порядку.
 
latestНа моем сайте недавно заметил, что модуль IceScroller, находящийся над строкой Breadcrumbs, стал неправильно выводить заголовки материалов, то есть на строке ниже положенной. Решил разобраться с модулем на локальном сайте в Denwer, да и пришло время сделать копию сайта. С помощью FTP скачал структуру сайта, с помощью phpmyadmin в менеджере сайта создал и скачал дамп БД. 
 
На виртуальном диске Y:/home cоздал папку /uk-optimist.local, внутри которой создал папку /www, в последнюю папку перенес скаченную структуру файлов. Запустил Denwer, в адресной строке запустил команду localhost/denwer. Создал пустую БД (логин и пароль). Импортировал в БД  скаченный дамп. Открыл конфигурационный файл, сделал изменения для БД и пользователя, изменил пути к папкам  logs и tmp.
В адресной строке браузера запустил uk-optimist.local. Появился локальный сайт, тождественный на хостинге.
 
Открыл следующую вкладку браузера и ввел адрес uk-optimist.local/administrator/
Появился … белый пустой экран!  При просмотре кода страницы тоже был пустой экран. В предыдущие месяцы при переносе данных с хостинга на локальный компьютер такого не наблюдалось.
 
Поискал в интернете подобные случаи появления белого экрана вместо административной панели. Пара часов поиска решения моей проблемы привели меня на сайт joomlablog.ru, где я нашел интересный, систематизированный и подробный материал о причинах появления белого экрана и варианты исправления ошибки.
 
Как я понял, моя ошибка стала результатом установки плагина скрытия админки kSecure от kareebu, который после переноса сайта с хостинга на локальный компьютер, был включен, но не настроен и поэтому надо было его отключить, то есть поставить в таблице myprefix_extensions в поле Enabled вместо 1 цифру 0. Как только плагин был отключен, команда uk-optimist.local/administrator/ открывала экран для ввода логина администратора и пароля.
 
Добиваться правильной работы плагина скрытия административной панели не имело смысла, ведь это локальный сайт и никто чужой к нему не проявит интерес. 
Ура! Проблема снята и можно приступить к экспериментам с модулем!
Спасибо автору Дмитрию Рекуну (joomlablog.ru)! 
 
Как исправил неправильный вывод строк модуля?
 
Зашел в административную панель, открыл расширения, открыл таблицу модулей и выбрал модуль mod_ice_scroller. На первой вкладке Рarameters в поле Module Width установил значение 650 пикс вместо 700 пикс. 
Для вступления в силу проведенных мной изменений надо зайти в меню Сайт, выбрать Обслуживание, выбрать Очистить весь кэш, пометить все чек-боксы  и нажать кнопку Удалить.
Открыть сайт и нажать две кнопки – Ctrl+F5 и, ура!, модуль стал правильно работать
 
 

You have no rights to post comments
У вас нет прав делать комментарии